Transfering libraries into Find Symbol area

Im a new user and started by deleting libraries from the library setup area to reduce the number of choices I had. However, I got carried away and deleted some that I realised I wanted. I have since put them back into the library setup area, but I cant see how to transfer them from here into the find symbol area where I can use them. I suspect this is a very silly question and there is a simple answer, but can anyone advise me how to do it.

On a related point, I thought by reinstalling / updating tinycad this would reset the libraries, but there is clearly a 'preferences' file somewhere that remembers what you have selected. How would I reset this to the 'out of the box' experience?


  • To add a new library to the find area, you need to click on the "Libraries" button and then from the Libraries dialogue add the library back in. The library will then be present in the Find Symbol tree.

    To reset TinyCAD back to it's "factory" settings you need to clear out the registry. TinyCAD has an entry here:


    Close TinyCAD and then delete this key from the registry using Regedi. Restart TinyCAD and it re-create the entry with the default values.

    I hope this helps,


  • Matt, thanks for your quick and helpful response which helped me find a workaround. I had '7 libraries in use' in the libraries dialogue box including 'Gen_Mechanical' but only 6 in the 'Find Symbol Tree', ie no Gen_Mechanical. I tried adding other libraries, as you suggested, and they installed and transferred fine. I then deleted the Gen_Mechanical in the libraries dialogue box to get the same number of libraries in each box, and tried to reinstall it. However, it again installed into the 'libraries in use' dialogue but not in the 'Find Symbol Tree'. I therefore tried installing an alternative library 'Mechanical' which has loaded OK and transferred to Find Symbol Tree and contains the symbols I need, so problem solved. However, I'm not sure if this issue with gen_mechanical is a 'bug' specific to my installation or if others have the same problem. I thought I would document in case someone else came across the same issue. Thanks for your help, it was really useful as I had only tried re-installing the gen_mechanical previously.

Sign In or Register to comment.