Missing DLLs

G'day all.

Not a good introduction to TinyCAD when I get 4 "missing dll" messages when I try to start TinyCAD 3.00.00r4 (on an Intel NUC with latest Win10) and TinyCAD doesn't start.

Two of the messages are the same (ie repeated)

The messages name the files: mfc140u.dll; VCRUNTIME140.dll (twice) and MSVCP140.dll

The missing dlls are not in the "C:/Program Files (x86/TinyCAD" folder, which I find perplexing.

The files mfc140u.dll, MSVCP140.dll and VCRUNTIME.dll are exactly where you would expect them to be - in "C:/Windows/System32".

If these files are required for TinyCAD to run, why doesn't the install program install them?

At the very least, the installer should either find and register the location of the files OR at least include the path to System 32.

It should not be up to the end user to find and copy these missing dll files to the TinyCAD install folder (C:/Program Files (x86)/TinyCAD"). I CAN do it but I shouldn't HAVE to.

Ahhhh .... hang on ... I just realised the version number ends in 00.00. Old timer PC users will no doubt remember the old saying - "Never install any programs ending on '0'" :-)

At this stage I assume it is an installer bug. Any comments?


Regards,

OziIan

Comments

  • Correction

    The files mfc140u.dll, MSVCP140.dll and VCRUNTIME.dll ...

    Should be The files mfc140u.dll, MSVCP140.dll and VCRUNTIME140.dll.


    When these files ARE copied from System32 into the TinyCAD folder, the messages go away BUT

    I now get a message "The application was unable to start correctly (0xc000007b). Click OK to close the application."

    SIGH!

    Back to ExpressSCH :-(

  • edited December 2019

    The error 0xc000007b is due to you copying the 64bit dlls instead of the 32bit dlls. Try installing the Visual Studio 32bit redistributable:

    https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads

    Can you remove the dlls and try running the installer (x86 version)? This is included in the installer but it looks like it didn't work on your system for some reason.

    I do have a blank Windows 10 VM that I use to test the installer, so I am not entirely sure why it didn't work for you.

    Perhaps once you have tried this, it would be great if you could share the results so that I can change the installer or update the documentation for other people?

  • edited December 2019

    G'day Matt.

    Thanks for a quick reply.

    Yes - copied wrong (64-bit) files. OOPS😚

    Removed 64-bit DLLs.

    Installed MS VS 32

    TC3 now up and running

    Many thanks, Matt.


    Ummm ... OK ... how do I mark this thread as 'Solved' ?

Sign In or Register to comment.